Delays in E-mail Delivery
Incident Report for PhotoLynx
Resolved
This incident has been resolved.
Posted Apr 06, 2020 - 19:14 CDT
Monitoring
Our e-mail delivery provider has reported that they fixed the issue with sending e-mails, however some emails are still being delayed. We will continue to monitor.
Posted Apr 06, 2020 - 18:43 CDT
Investigating
Our e-mail delivery provider is experiencing some delays in sending e-mails. E-mails for PLIC accounts may be significantly delayed while they work to resolve this, including user invitation emails and password reset links. Thank you for your patience.
Posted Apr 06, 2020 - 18:29 CDT
This incident affected: Notifications Services (Mandrill - Emails (US East), Mandrill - Emails (US West)).